PXE-E55 ProxyDHCP service did not reply to request on port 4011

by getdeclue on October 12, 2011

This error comes up when PXE booting a computer to a Windows Deployment Server. The error can be difficult to troubleshoot.

There are two possible solutions, check the server that Windows Deployment Services is running on and make sure the “Windows Deployment Services Server” service is started on the server. If the status of it is not started then you should start it manually.

This error can also occur when a computer was previously approved or rejected on the Windows Deployment server and therefore needs to be removed in order to connect properly.

The command to remove a computer from the cache in windows deployment services is as follows:

C:\Windows\System32\WDSUTIL.exe /Delete-AutoAddDevices [/Server:<Server name>] /DeviceType:{PendingDevices | RejectedDevices |ApprovedDevices

I usually run theses two commands on the server:

C:\Windows\System32\wdsutil.exe /Delete-AutoAddDevices /DeviceType:ApprovedDevices

C:\Windows\System32\wdsutil.exe /Delete-AutoAddDevices /DeviceType:RejectedDevices

If you continue to have problems connecting to WDS you should check which port is proper for your configuration and make sure you have the settings correct in WDS and on the DHCP server in which case I recommend you review the technet documentation: http://technet.microsoft.com/en-us/library/cc771670(WS.10).aspx#BKMK_ConfiguringDS

{ 5 comments }

Elliptical reviews December 19, 2011 at 2:51 am

Glad to read this blog! Keep it going!

gok kast December 28, 2011 at 11:58 am

hi i came to youre blog, and I have read some awesome information on it.

Adrian August 13, 2012 at 7:20 pm

Thanks for this. Saved me a whole day of troubleshooting two machines, as to why they would not PXE boot! They are now being imaged and we will happy, calm, end users, not angry screaming ones 🙂

Andy February 21, 2013 at 7:24 am

When I run either of the above wdsutil commands I get the following error.

An error occurred while trying to execute the command.
Error Code: 0x139F
Error Description: The group or resource is not in the correct state to perform
the requested operation.

getdeclue February 28, 2013 at 1:31 pm

Make sure your command prompt window has been run as an administrator and it includes the path location of wdsutil which is C:\Windows\System32

Previous post:

Next post: